PHP RFC: Casing of acronyms in class and method names


The results of the Class Naming RFC decided that class names should be written in PascalCase (“Upper Camel Case”), with the exception of acronyms, which should be included in UPPERCASE. This RFC proposes to revisit the prior decision, instead treating acronyms like regular words, making classnames consistent PascalCase.


It is not consistently applied

As an example ext/json has JsonException which should've been JSONException according to the previous RFC’s results. In fact JsonException’s RFC was created just 3 months (!) after the class naming RFC in September 2017.

Another example is ext/curl which has both CurlHandle and CURLFile. CURLFile predates the RFC, but there's also CURLStringFile which was added in PHP 8.1 and likely followed CURLFile’s naming for consistency, but violating the RFC and being inconsistent with CurlHandle.

ext/random’s Random\Engine\PcgOneseq128XslRr64 would've needed to be called Random\Engine\PCGOneseq128XSLRR64 according to the class naming RFC.

The PDO driver specific sub-classes RFC voted (and accepted) for PHP 8.3 and implemented in PHP 8.4 uses Pdo<Driver>, e.g. PdoOdbc instead of PDOODBC.

It decreases readability

It is well-established in accessibility circles that ALL CAPS text is harder to read than Mixed Case, as mixed case provides greater vertical variation between letters, making it easier to read, especially for people with various reading disorders.

Most accessibility organizations recommend against ALL CAPS. For example:

That issue is amplified if multiple acronyms follow each other. One example is the PCGOneseq128XSLRR64 mentioned above: It’s not clear that XSL (XorShiftLow) and RR (RandomlyRotate) are two different acronyms.

Likewise PDOODBC is much harder to parse than PdoOdbc.

Another example might be JavaScript’s XMLHttpRequest which incidentally mixes both variants. According to the class naming RFC it would need to be called XMLHTTPRequest, resulting in 8 consecutive uppercase characters.

The userland convention is mostly MixedCase

Although there is no formal standard in userland for handling initialisms, the most widely used convention is to only capitalize the first letter. For example:

Although this RFC has no direct impact on userland code, normalizing conventions between Internals and userland has many benefits. The PER-CS working group, part of the PHP-FIG, has been asked to adopt a standard for initialisms and would likely follow suit with this RFC if passed.


Update to the Policy

The class naming policy should be updated to the following, with changes highlighted:

Method names follow the studlyCaps (also referred to as bumpy case or camel caps) naming convention, with care taken to minimize the letter count. The initial letter of the name is lowercase, and each letter that starts a new word is capitalized.

Class names should be descriptive nouns in PascalCase and as short as possible. Each word in the class name should start with a capital letter, without underscore delimiters. The class name should be prefixed with the name of the “parent set” (e.g. the name of the extension) if no namespaces are used.

Abbreviations and acronyms as well as initialisms should be avoided wherever possible, unless they are much more widely used than the long form (e.g. HTTP or URL). Abbreviations start with a capital letter followed by lowercase letters, whereas acronyms and initialisms are written according to their standard notation. Abbreviations, acronyms, and initialisms should be treated like regular words, thus they should be written with an uppercase first character, followed by lowercase characters. Usage of acronyms and initialisms is not allowed if they are not widely adopted and recognized as such.

Diverging from this policy is allowed to keep internal consistency within a single extension, if the name follows an established, language-agnostic standard, or for other reasons, if those reasons are properly justified and voted on as part of the RFC process.


Good method names:


Bad method names:


Good class names:

BtreeMap // B-tree Map
UserId // User Identifier
Char // Character
Intl // Internationalization
Ssl\Crl // Certificate Revocation List

Bad class names:

UserID // User Identifier

Adjusting class & method names added in PHP 8.4

The DOM HTML5 parsing and serialization RFC introduced new class names and method names that violate the updated naming policy, should this RFC be accepted. As part of this RFC, the following changes will be made:

  • The DOM namespace will be renamed to Dom, affecting everything contained within it.
  • DOM\DTDNamedNodeMap -> Dom\DtdNamedNodeMap
  • DOM\HTMLCollection -> Dom\HTMLCollection (Justification: The DOM Standard specifies the name)
  • DOM\CDATASection -> Dom\CDATASection (Justification: The DOM Standard specifies the name)
  • DOM\HTMLDocument -> Dom\HTMLDocument (Justification: Consistency with XMLDocument)
  • DOM\XMLDocument -> Dom\XMLDocument (Justification: The DOM Standard specifies the name)
  • DOM\XPath -> Dom\XPath (Justification: The DOM Standard specifies the XPath interfaces that use this casing)
  • DOM\Implementation::createHTMLDocument() -> Dom\Implementation::createHtmlDocument()
  • DOM\Node::lookupNamespaceURI() -> Dom\Node::lookupNamespaceURI() (Justification: The DOM Standard specifies the name)
  • DOM\*::*NS() -> Dom\*::*NS() (Justification: The DOM Standard generally specifies the NS suffix in this casing)
  • DOM\DocumentFragment::appendXML() -> Dom\DocumentFragment::appendXml()
  • DOM\Document::createCDATASection() -> Dom\Document::createCDATASection() (Justification: The DOM Standard specifies the name)
  • DOM\Document::relaxNGValidate() -> Dom\Document::relaxNgValidate()
  • DOM\Document::relaxNGValidateSource() -> Dom\Document::relaxNgValidateSource()
  • DOM\HTMLDocument::saveXML() -> Dom\HTMLDocument::saveXml()
  • DOM\HTMLDocument::saveXMLFile() -> Dom\HTMLDocument::saveXmlFile()
  • DOM\HTMLDocument::saveHTML() -> Dom\HTMLDocument::saveHtml()
  • DOM\HTMLDocument::saveHTMLFile() -> Dom\HTMLDocument::saveHtmlFile()
  • DOM\XMLDocument::saveXML() -> Dom\XMLDocument::saveXml()
  • DOM\XMLDocument::saveXMLFile() -> Dom\XMLDocument::saveXmlFile()

For the Improve callbacks in ext/dom and ext/xsl RFC the following changes will be made:

  • \DOMXPath::registerPhpFunctionNS() -> \DOMXPath::registerPhpFunctionNS() (Justification: Consistency with the *NS() methods in ext/dom)
  • \DOM\XPath::registerPhpFunctionNS() -> \Dom\XPath::registerPhpFunctionNS() (Justification: see above)
  • \XSLTProcessor::registerPHPFunctionNS() -> \XSLTProcessor::registerPHPFunctionNS() (Justification: Consistency with \XSLTProcessor::registerPHPFunctions(), which unfortunately is inconsistent with \DOMXPath).

Backward Incompatible Changes

Existing class and method names in released versions are not affected, thus there are not backwards incompatible changes. This is a policy RFC.

Proposed PHP Version(s)

Next PHP 8.x (PHP 8.4).

RFC Impact


SAPIs that expose classes should take the RFC results into account.

To Existing Extensions

Extensions should take the RFC results into account.

To Opcache


New Constants


php.ini Defaults


Open Issues


Unaffected PHP Functionality

Everything that is not a class name of an internal class. Everything that is already in PHP.

Future Scope


Proposed Voting Choices

Adopt the updated class naming policy and adjust the new names introduced in PHP 8.4?
Real name yes no
alcaeus (alcaeus)  
beberlei (beberlei)  
crell (crell)  
devnexen (devnexen)  
dharman (dharman)  
ericmann (ericmann)  
galvao (galvao)  
girgias (girgias)  
ilutov (ilutov)  
kguest (kguest)  
klaussilveira (klaussilveira)  
kocsismate (kocsismate)  
mauricio (mauricio)  
mbeccati (mbeccati)  
nicolasgrekas (nicolasgrekas)  
nielsdos (nielsdos)  
ocramius (ocramius)  
petk (petk)  
ramsey (ramsey)  
saki (saki)  
sergey (sergey)  
theodorejb (theodorejb)  
thorstenr (thorstenr)  
timwolla (timwolla)  
Final result: 23 1
This poll has been closed.

Patches and Tests



Rejected Features


rfc/class-naming-acronyms.txt · Last modified: 2024/05/08 18:55 by timwolla