internals:windows:windowssdk

Differences

This shows you the differences between two versions of the page.

Link to this comparison view

Both sides previous revision Previous revision
Next revision
Previous revision
internals:windows:windowssdk [2008/12/14 15:41]
auroraeosrose Some rewording to make this easier to understand
internals:windows:windowssdk [2017/09/22 13:28] (current)
Line 3: Line 3:
 When building on windows - you should NOT use the default SDK included with VC6 or VC9, instead you need to get a newer SDK. When building on windows - you should NOT use the default SDK included with VC6 or VC9, instead you need to get a newer SDK.
  
-If you are using VC6 you will need the Windows Server Feb. 2003 SDK and the Microsoft .NET 2.0 SDK for the com/dotnet extension.+If you are using VC6 you will need the Windows Server Feb. 2003 SDK.
  
   * [[http://www.microsoft.com/msdownload/platformsdk/sdkupdate/psdk-full.htm|Windows Server 2003 PSDK]]   * [[http://www.microsoft.com/msdownload/platformsdk/sdkupdate/psdk-full.htm|Windows Server 2003 PSDK]]
-  * [[http://www.microsoft.com/downloads/details.aspx?FamilyID=fe6f2099-b7b4-4f47-a244-c96d69c35dec&displaylang=en|Microsoft .Net SDK 2.0]] 
  
-All [[http://www.php.net/downloads|official releases]] or [[http:\\snaps.php.net|snaps]] are built using VC6 with SP6 and this SDK. +All [[http://www.php.net/downloads/|official releases]] or [[http://windows.php.net/snapshots/|snaps]] are built using VC6 with SP6 and this SDK. 
  
 If you are using VC9 you need to use the Windows SDK for Windows Server 2008 and .NET Framework 3.5 (also known as the SDK 6.1) If you are using VC9 you need to use the Windows SDK for Windows Server 2008 and .NET Framework 3.5 (also known as the SDK 6.1)
Line 14: Line 13:
   * [[http://www.microsoft.com/downloads/details.aspx?FamilyID=e6e1c3df-a74f-4207-8586-711ebe331cdc&displaylang=en#Overview|SDK 6.1]]   * [[http://www.microsoft.com/downloads/details.aspx?FamilyID=e6e1c3df-a74f-4207-8586-711ebe331cdc&displaylang=en#Overview|SDK 6.1]]
  
-SDK 6.1 is used for the PHP 5.3 VC9 builds currently available as snapshots and QA release at [[http://windows.php.net]]. Our upcoming official PHP6 release built with VC9 (x86 and x64) will use it as well.+SDK 6.1 is used for the PHP 5.3 and 6.0 VC9 builds currently available as snapshots and QA release at [[http://windows.php.net]]. Our upcoming official PHP6 release built with VC9 (x86 and x64) will use it as well. 
 + 
 + 
 + 
 +===== Note about the Platform SDK 2003: ===== 
 + 
 +**INSTALL THE FULL SDK IF YOU DO NOT WANT TO RUN IN ALL POSSIBLE ISSUES AFTERWARDS, EVEN IF OTHER DOCS/TUTORIALS/PERSONS RECOMMEND TO ONLY INSTALL PART OF IT. We won't help you if it is not fully installed.** 
 + 
 +==== Note ==== 
 + 
 +If you are creating your setup from scratch, then please read the following notice and blogs from Microsoft regarding an issue of installing the 6.1 SDK on top of VC9 SP1 : 
 +  - [[http://www.microsoft.com/downloads/en/details.aspx?FamilyID=e6e1c3df-a74f-4207-8586-711ebe331cdc&displaylang=en|Windows SDK for Windows Server 2008 and .NET Framework 3.5]] 
 +  - [[http://blogs.msdn.com/b/windowssdk/archive/2009/08/07/windows-sdk-for-server-2008-v6-1-overwrites-vs2008-sp1-crt-files.aspx|Windows SDK for Server 2008 (v6.1) overwrites VS2008 SP1 CRT files]] 
 +  - [[http://blogs.msdn.com/b/windowssdk/archive/2009/08/07/installing-windows-sdk-for-server-2008-v6-1-after-vs2008-sp1-causes-conflicts-with-security-update-kb971092.aspx|Installing Windows SDK for Server 2008 (v6.1) after VS2008 SP1 causes conflicts with Security Update (KB971092)]] 
 + 
 +Installing the 6.1 SDK before installing VC9SP1 is the recommended route. After that, any additional security patches or updates can be applied. 
internals/windows/windowssdk.1229269285.txt.gz · Last modified: 2017/09/22 13:28 (external edit)