internals:windows:windowssdk

Supported Windows/Platform SDK

When building on windows - you should NOT use the default SDK included with VC6 or VC9, instead you need to get a newer SDK.

If you are using VC6 you will need the Windows Server Feb. 2003 SDK.

All official releases or snaps are built using VC6 with SP6 and this SDK.

If you are using VC9 you need to use the Windows SDK for Windows Server 2008 and .NET Framework 3.5 (also known as the SDK 6.1)

SDK 6.1 is used for the PHP 5.3 and 6.0 VC9 builds currently available as snapshots and QA release at http://windows.php.net. Our upcoming official PHP6 release built with VC9 (x86 and x64) will use it as well.

Note about the Platform SDK 2003:

INSTALL THE FULL SDK IF YOU DO NOT WANT TO RUN IN ALL POSSIBLE ISSUES AFTERWARDS, EVEN IF OTHER DOCS/TUTORIALS/PERSONS RECOMMEND TO ONLY INSTALL PART OF IT. We won't help you if it is not fully installed.

Note

If you are creating your setup from scratch, then please read the following notice and blogs from Microsoft regarding an issue of installing the 6.1 SDK on top of VC9 SP1 :

Installing the 6.1 SDK before installing VC9SP1 is the recommended route. After that, any additional security patches or updates can be applied.

internals/windows/windowssdk.txt · Last modified: 2011/04/06 12:59 (external edit)