rfc:deprecate-and-remove-ext-interbase

Differences

This shows you the differences between two versions of the page.

Link to this comparison view

Both sides previous revision Previous revision
Next revision
Previous revision
rfc:deprecate-and-remove-ext-interbase [2019/03/24 13:08]
kalle
rfc:deprecate-and-remove-ext-interbase [2019/05/07 08:28]
kalle
Line 1: Line 1:
 ====== PHP RFC: Unbundle ext/interbase ====== ====== PHP RFC: Unbundle ext/interbase ======
  
-  * Version: 1.0.2+  * Version: 1.0.3
   * Date: 2019-03-22   * Date: 2019-03-22
   * Author: Kalle Sommer Nielsen <kalle@php.net>   * Author: Kalle Sommer Nielsen <kalle@php.net>
-  * Status: Under discussion+  * Status: Implemented
   * First Published at: https://wiki.php.net/rfc/deprecate-and-remove-ext-interbase   * First Published at: https://wiki.php.net/rfc/deprecate-and-remove-ext-interbase
  
Line 15: Line 15:
 ===== Proposal ===== ===== Proposal =====
  
-Given the unacceptable nature of the status of this extension, I therefore propose consider the deprecation and removal of this extension. The voting proposals below will be used to decide on the strategy.+Given the unacceptable nature of the status of this extension, I therefore propose consider the move of this extension to PECL in 7.4.0.
  
 ===== Backward Incompatible Changes ===== ===== Backward Incompatible Changes =====
  
-Obviously, code using the interbase extension would issue deprecation warnings, and/or would have to use the PDO_Firebird extension in the Core in 8.0.+Codebases relying on ext/interbase to be available with the default PHP build (like on Windows) will have to download it from PECLFor Unix systems that have packages, the package managers may need to be pointed to PECL to continue having gaining access to an InterBase/Firebird based database.
  
 ===== Further rationale ===== ===== Further rationale =====
Line 39: Line 39:
 ===== Voting ===== ===== Voting =====
  
-The primary vote is about whether to unbundle ext/interbase, which requires a 2/3 majority and will run for 2 weeks:+The primary vote is about whether to unbundle ext/interbase, which requires a 2/3 majority and will run for 2 weeks (2019-04-09 to 2019-04-23 ~12:00 EET):
  
-<doodle title="Unbundle ext/interbase" auth="kalle" voteType="single" closed="true">+<doodle title="Move ext/interbase to PECL" auth="kalle" voteType="single" closed="true">
    * Yes    * Yes
    * No    * No
 </doodle> </doodle>
- 
-The secondary vote decides on the strategy for unbundling ext/interbase, which will run at the same time as the primary one: 
- 
-<doodle title="Unbundling strategy for ext/interbase" auth="kalle" voteType="single" closed="true"> 
-   * Move to PECL in 7.4 
-   * Remove in 7.4 
-   * Deprecate in 7.4, Move to PECL in 8.0 
-   * Deprecate in 7.4, Remove in 8.0 
-</doodle> 
- 
-===== Patches and Tests ===== 
- 
-None, yet. 
  
 ===== References ===== ===== References =====
  
   * Internals discussion: [[http://news.php.net/php.internals/104871]]   * Internals discussion: [[http://news.php.net/php.internals/104871]]
- 
-===== Rejected Features ===== 
- 
-None. 
rfc/deprecate-and-remove-ext-interbase.txt · Last modified: 2019/05/07 08:28 by kalle